The scheduled Telemetry MongoDB upgrade has been successfully completed. Our team is actively monitoring system performance to ensure that everything is running smoothly after upgrade.
Posted Mar 21, 2025 - 11:21 CET
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 21, 2025 - 08:00 CET
Scheduled
We're upgrading our MongoDB infrastructure to improve stability and performance following recent issues. This upgrade is designed to be seamless, with no expected downtime. All services will remain operational.