Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 08, 2025 - 10:00 CEST
Scheduled
We will be deploying major changes with a significant upgrade in the performance of processing Bulk Operations and Device Policies. To accurately measure the improvement, we will conduct several scaling, performance, and stress tests for analysis and reporting purposes.
Services should remain operational during deployment and testing. We expect only slight degradation, of no more than hundreds of milliseconds per operation, during stress testing.
Posted Oct 04, 2025 - 15:17 CEST
This scheduled maintenance affected: API, Box, and Platform.