Degredated read performance of telemetry data

Incident Report for signageOS

Resolved

This incident has been resolved.
Posted Jul 16, 2025 - 17:49 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2025 - 17:25 CEST

Investigating

We are detecting a degraded performance of our MongoDB database that contains telemetry data. Clients may experience performance degradation when reading this data via API or Box. Team is investigating.
Posted Jul 16, 2025 - 16:59 CEST
This incident affected: API and Box.