Device telemetry delay

Incident Report for signageOS

Postmortem

Date

August 27, 2025

Authors

signageOS Engineering Team

Summary

On August 27, the signageOS platform experienced an incident related to processing of device telemetry and system data. Some backend services became temporarily overloaded, resulting in delays in telemetry reporting and increased system traffic.

No deployed devices or their content playback were affected during this incident.

Impact

  • No impact on device playback or end-user experience.

  • Telemetry and system log data experienced processing delays.

  • Some device status information and background monitoring services were temporarily degraded.

  • A limited number of telemetry messages were delayed or had to be re-sent from devices.

  • Persistent business-critical data remained intact.

Detection

The issue was detected by internal monitoring systems and confirmed by the engineering team through analysis of service health and system logs.

Contributing Factors

  • A sudden concentration of high-volume data processing exceeded normal thresholds.

  • Automated retry logic added additional pressure on backend systems during the peak.

  • Some data types that were not essential under peak load contributed to overall system strain.

Mitigation & Resolution

Engineering teams applied configuration changes and service adjustments to stabilize processing and reduce unnecessary load. Certain non-critical data handling was deprioritized to restore the system more efficiently.

Normal processing was restored after mitigation, with follow-up actions scheduled to strengthen resilience.

Posted Aug 29, 2025 - 20:40 CEST

Resolved

This incident has been resolved.
Posted Aug 27, 2025 - 18:16 CEST

Identified

The issue has been identified and we are working on a fix. Only some telemetries is impacted - firmware, pin, OS, serial number and brand
Posted Aug 27, 2025 - 16:58 CEST

Investigating

We are experiencing an internal system issue that negatively impacts collection of telemetry from devices.
Posted Aug 27, 2025 - 14:53 CEST
This incident affected: Platform.